Father's Day order deadlines
Help Centre
Software
  • When I open my recipe book .mbk file, a ‘Locate missing photos’ message appears. What can I do?
  • How do I Export / Finish a project?
  • Will HEIC files work with Momento software?
  • How do I move text from a Word document into the Momento software?
  • Do you have any themed templates for photo greeting cards?
Website
  • What type of paper are Momento photo greeting cards printed on?
  • How do I find out when my order will be sent?
  • How can I add multiple Projects to the same order?
  • I am having trouble signing in to the Momento website?
  • The website is saying I have ordered my project twice but I only want one copy. How can I check this?
Products & Services
  • When do I choose the cover material for my photo book?
  • How do I make sure my cover design is printed on my book?
  • Where do Momento make their products?
  • What sizes and shapes are available for recipe books?
  • What recipe book paper stock is the easiest to keep clean?
Production
  • Where do Momento make their products?
  • What is the production time for a photo book?
  • What is the production time for photo calendars?
  • What is the production time for photo diaries?
  • What is the production time for photo notebooks?
Miscellaneous
  • What if I need help?
  • I live overseas. Do you ship to international addresses?
  • What is the best way to store my book?
  • What is Momento?
General
  • When do I choose the cover material for my photo book?
  • What if I need help?
  • Where are Momento products made?
  • I live overseas. Do you ship to international addresses?
  • How do I update my personal details (address/email/phone number etc) ?
Orders & Payments
  • How do I reorder a book I have already ordered?
  • What type of paper are Momento photo greeting cards printed on?
  • How much do photo calendars cost?
  • Can pages be added to my spiral diary?
  • What is the Postage/delivery cost for Greeting Cards?

Software Interface

This section is designed to familiarise you with the various elements of the software interface making it easy for you to navigate your way around the software.

  • A. Main Toolbar:  guides you through the mains 'views' of project creation
  • B. Canvas:  the large work area where you create your layouts
  • C. Content Panels:  five panels of content to add to your projects
  • D. Tools Panels:  a range of tools to adjust your layouts, download extra content and upload your project
  • E. Pages Panel:  panel of thumbnails across the base of the screen (Layout View only)
  • F. Menus:  the program menus that give access to all features

Main Toolbar

There are five different views in the software that guide you step-by-step through the creation process.  You can move between the different views by clicking on the icons in the main toolbar.

  1. Start View:  where you start a new project, choose the product, shape, size & layout style
  2. Sort View:  displays content as a list of icons for you to sequence, size, add or delete pages
  3. Layout View:  where you do all the designing of your pages and cover, adding photos, text and embellishments
  4. Preview:  a non-editable full screen preview of your project
  5. Export View:  saves your project to a single Master File (MBF) for uploading, and creates a PROOF.pdf file

The Canvas

The canvas is where you do all your designing. It appears different according to which view you are in. The canvas in Layout View and Cover View is an almost full-screen presentation of your page design and all its contents in graphical form. The canvas in Sort View however presents a list of your content represented as icons. To add any content to your project in Sort View, Layout View or Cover View, simply drag the item from the Contents Panel on to the canvas.

Content Panels

Five panels give you access to content that can be inserted onto the pages of your project. 

  1. Photos:  all your photos stored on your computer
  2. Backgrounds:  colourful or themed designs to fill the page background
  3. Frames:  a range of borders and corners to enhance your photos
  4. Layouts:  pre-designed page layouts
  5. Embellishments:  hundreds of themed graphics to add to your layouts

Tools Panel

  • Tools: tools to change the appearance, colour, position & size of your photos
  • Updater: to download additional themed content - page templates, backgrounds, frames, embellishments
  • Uploader: to upload your completed project, once exported to a Master File
  • Inspiration: filled with news about competitions, new products & design tips
  • Quick Help: handy summary of the main tools in each view & Keyboard Shortcuts

For more information please see Tools, Updater and Quick Help.

Pages Panel

This panel shows a thumbnail view of all the pages in your project and allows you to access any page by scrolling horizontally, then clicking on the desired page.

Menus

The standard software menu at the top left of the interface links you to all the functions, screens, tools and settings in the software.

File Menu

     

Edit Menu

    

View Menu

    

Page Menu

             

Photo Menu

 

Text Menu

 

Layout Menu

   
Help?